Learn R Programming

astsa (version 1.1)

arma.spec: Spectral Density of an ARMA Model

Description

Gives the ARMA spectrum (on a log scale), tests for causality, invertibility, and common zeros. See Example 4.6 on page 184.

Usage

arma.spec(ar = 0, ma = 0, var.noise = 1, n.freq = 500, ...)

Arguments

ar
vector of AR parameters
ma
vector of MA parameters
var.noise
variance of the noise
n.freq
number of frequencies
...
additional arguments

Value

  • freqfrequencies - returned invisibly
  • specspectral ordinates - returned invisibly

Details

The basic call is arma.spec(ar, ma) where ar and ma are vectors containing the model parameters. Use log="no" if you do not want the plot on a log scale. If the model is not causal or invertible an error message is given. If there are common zeros, a spectrum will be displayed and a warning will be given; e.g., arma.spec(ar= .9, ma= -.9) will yield a warning and the plot will be the spectrum of white noise. See Example 4.6 on page 184.

References

http://www.stat.pitt.edu/stoffer/tsa3/

Examples

Run this code
arma.spec(ar = c(1, -.9), ma = .8, log="no")

Run the code above in your browser using DataLab