bamlss (version 1.2-3)

smooth.construct.kr.smooth.spec: Kriging Smooth Constructor

Description

This smooth constructor implements a kriging based model term.

Usage

# S3 method for kr.smooth.spec
smooth.construct(object, data, knots, ...)
# S3 method for kriging.smooth
Predict.matrix(object, data)

Value

A smooth specification object, see also smooth.construct.

Arguments

object, data, knots

See smooth.construct.

...

Currently not used.

Details

This smooth constructor implements univariate and bivariate Kriging terms. The basis functions are based on the Matern covariance function. For finding knots, a space filling algorithm is used, see cover.design.

References

Fahrmeir, L., Kneib, T. , Lang, S., Marx, B. (2013): Regression. Models, Methods and Applications, Springer Verlag. https://www.uni-goettingen.de/de/551357.html

See Also

Examples

Run this code
if (FALSE) ## Simulate data.
set.seed(123)
d <- GAMart()

## Estimate model.
f <- num ~ s(x1,bs="kr") + s(x2,bs="kr") + s(x3,bs="kr") + s(lon,lat,bs="kr",k=30)

## Set the seed, estimate model.
set.seed(111)
b <- bamlss(f, data = d)

## Plot estimated effects.
plot(b)

Run the code above in your browser using DataLab