Learn R Programming

bamlss (version 1.2-5)

smooth.construct.sr.smooth.spec: Random Effects P-Spline

Description

This smooth constructor implements the random effects representation of a P-spline.

Usage

# S3 method for sr.smooth.spec
smooth.construct(object, data, knots, ...)

Value

See smooth.construct

Arguments

object, data, knots

See smooth.construct.

...

Currently not used.

See Also

bamlss, predict.bamlss, opt_bfit, opt_boost

Examples

Run this code
if (FALSE) ## Simulate data.
set.seed(123)
d <- GAMart()

## Estimate model.
f <- num ~ x1 + x2 + x3 + s2(x1,bs="sr") + s2(x2,bs="sr") + s2(x3,bs="sr")

b <- bamlss(f, data = d, optimizer = boost, sampler = FALSE)

plot(b)

Run the code above in your browser using DataLab