parse_deps

0th

Percentile

Parse package dependency strings.

Parse package dependency strings.

Keywords
internal
Usage
parse_deps(string)
Arguments
string

to parse. Should look like "R (>= 3.0), ggplot2" etc.

Value

list of two character vectors: name package names, and version package versions. If version is not specified, it will be stored as NA.

Aliases
  • parse_deps
Examples
# NOT RUN {
parse_deps("httr (< 2.1),\nRCurl (>= 3)")
# only package dependencies are returned
parse_deps("utils (== 2.12.1),\ntools,\nR (>= 2.10),\nmemoise")
# }
Documentation reproduced from package pkgload, version 1.0.0, License: GPL-3

Community examples

Looks like there are no examples yet.