update_packages

0th

Percentile

Update packages that are missing or out-of-date.

Works similarly to install.packages() but doesn't install packages that are already installed, and also upgrades out dated dependencies.

Usage
update_packages(packages, dependencies = NA, repos = getOption("repos"),
  type = getOption("pkgType"))
Arguments
packages

Character vector of packages to update.

dependencies

Which dependencies do you want to check? Can be a character vector (selecting from "Depends", "Imports", "LinkingTo", "Suggests", or "Enhances"), or a logical vector.

TRUE is shorthand for "Depends", "Imports", "LinkingTo" and "Suggests". NA is shorthand for "Depends", "Imports" and "LinkingTo" and is the default. FALSE is shorthand for no dependencies (i.e. just check this package, not its dependencies).

repos

A character vector giving repositories to use.

type

Type of package to update. If "both", will switch automatically to "binary" to avoid interactive prompts during package installation.

See Also

package_deps to see which packages are out of date/ missing.

Aliases
  • update_packages
Examples
# NOT RUN {
update_packages("ggplot2")
update_packages(c("plyr", "ggplot2"))
# }
Documentation reproduced from package remotes, version 1.0.0, License: GPL (>= 2)

Community examples

Looks like there are no examples yet.