requireversion

0th

Percentile

Require a Specific Version of a Package

Checks that the version number of a specified package is greater than or equal to the specified version number. For use in stand-alone R scripts.

Keywords
environment
Usage
requireversion(pkg, ver)
Arguments
pkg

Package name.

ver

Character string containing version number.

Details

This function checks whether the installed version of the package pkg is greater than or equal to ver.

It is useful in stand-alone R scripts, which often require a particular version of a package in order to work correctly.

This function should not be used inside a package: for that purpose, the dependence on packages and versions should be specified in the package description file.

Value

Null.

Aliases
  • requireversion
Examples
# NOT RUN {
   
# }
# NOT RUN {
      requireversion(spatstat, "1.42-0")
   
# }
Documentation reproduced from package spatstat, version 1.57-1, License: GPL (>= 2)

Community examples

Looks like there are no examples yet.