PortfolioAnalytics (version 1.1.0)

mult.portfolio.spec: Multple Layer Portfolio Specification

Description

Create and specify a multiple layer portfolio

Usage

mult.portfolio.spec(portfolio, levels = 2, ...)

Arguments

portfolio

the "top level" portfolio

levels

number of levels of sub-portfolios

any additional parameters

Value

a mult.portfolio.spec object with the top level portfolio and sub portfolios with optimization parameters for each sub portfolio

Details

The sub.portfolios slot is a list where each element contains the portfolio object and rebalancing parameters for the optimization of the sub portfolio. This allows, for example, each sub portfolio to have different rebalancing frequencies (i.e. monthly or quarterly), optimization methods, etc.

Each sub portfolio is optimized with optimize.portfolio.rebalancing to create a time series of proxy returns.

The "top level" portfolio is used to specify the constraints and objectives to control the optimization given the proxy returns of each sub portfolio.