# NOT RUN {
## Simulate data.
set.seed(123)
d <- GAMart()
## Estimate model.
f <- num ~ s(x1,bs="kr") + s(x2,bs="kr") + s(x3,bs="kr") + s(lon,lat,bs="kr",k=30)
## Set the seed, estimate model.
set.seed(111)
b <- bamlss(f, data = d)
## Plot estimated effects.
plot(b)
# }
Run the code above in your browser using DataLab