bamlss (version 1.1-2)

smooth.construct.sr.smooth.spec: Random Effects P-Spline

Description

This smooth constructor implements the random effects representation of a P-spline.

Usage

# S3 method for sr.smooth.spec
smooth.construct(object, data, knots, ...)

Arguments

object, data, knots

Currently not used.

Value

See smooth.construct

See Also

bamlss, predict.bamlss, bfit, boost

Examples

Run this code
# NOT RUN {
## Simulate data.
set.seed(123)
d <- GAMart()

## Estimate model.
f <- num ~ x1 + x2 + x3 + s2(x1,bs="sr") + s2(x2,bs="sr") + s2(x3,bs="sr")

b <- bamlss(f, data = d, optimizer = boost, sampler = FALSE)

plot(b)
# }

Run the code above in your browser using DataLab